Web Fonts Working Group - Activity in 2023
No matches.
Past meetings
-
1 meeting.
GitHub
w3c/ift-encoder
-
1 pull request opened.
-
Add support for VF design space augmentation w3c/ift-encoder#81, by @garretrieger.
-
-
1 pull request merged.
-
Add support for VF design space augmentation w3c/ift-encoder#81.
-
Past meetings
-
1 meeting.
Participants
-
1 participant left.
-
Myles Maxfield (Apple Inc.) left.
-
GitHub
w3c/ift-encoder
-
5 pull requests opened.
-
Some minor refactoring. w3c/ift-encoder#80, by @garretrieger.
-
Add support for augmenting by features. w3c/ift-encoder#79, by @garretrieger.
-
Update encoder to ensure loca length stays the same in mixed mode. w3c/ift-encoder#78, by @garretrieger.
-
Add unique ptr's for hb_face/font/blob_t and fix memory leaks found in tests. w3c/ift-encoder#77, by @garretrieger.
-
Implement support for mixed shared brotli and IFTB patches in the same font. w3c/ift-encoder#76, by @garretrieger.
-
-
5 pull requests merged.
-
Some minor refactoring. w3c/ift-encoder#80.
-
Add support for augmenting by features. w3c/ift-encoder#79.
-
Update encoder to ensure loca length stays the same in mixed mode. w3c/ift-encoder#78.
-
Add unique ptr's for hb_face/font/blob_t and fix memory leaks found in tests. w3c/ift-encoder#77.
-
Implement support for mixed shared brotli and IFTB patches in the same font. w3c/ift-encoder#76.
-
w3c/woff
-
1 pull request merged.
-
1 pull request received 4 new comments.
-
Feature/Add Python 3 compatibility to WOFF validator w3c/woff#7 (4 comments by @garretrieger, @w3cbot)
-
w3c/IFT
-
1 pull request opened.
-
Update references to RFC9110, RFC9111 and RFC9112 w3c/IFT#154, by @tidoust.
-
-
1 pull request merged.
-
Update references to RFC9110, RFC9111 and RFC9112 w3c/IFT#154.
-
-
1 pull request received 1 new comment.
w3c/PFE-analysis
-
1 pull request closed.
-
Add validation to merge tool. w3c/PFE-analysis#97.
-
Past meetings
-
1 meeting.
GitHub
w3c/ift-encoder
-
2 pull requests opened.
-
Demo updates w3c/ift-encoder#75, by @garretrieger.
-
Add code for testing out static IFT. w3c/ift-encoder#74, by @garretrieger.
-
-
2 pull requests merged.
-
Demo updates w3c/ift-encoder#75.
-
Add code for testing out static IFT. w3c/ift-encoder#74.
-
w3c/woff
-
3 issues opened.
-
Bit array not defined w3c/woff#30, by @Lorp.
-
Clarify WOFF2 header majorVersion and minorVersion w3c/woff#28, by @Lorp.
-
-
1 issue closed.
-
Bit array not defined w3c/woff#30.
-
-
1 issue received 1 new comment.
Past meetings
GitHub
w3c/IFT
-
9 issues closed.
-
Range requests and preflights w3c/IFT#34.
-
Specifying Range Request implementation details w3c/IFT#79.
-
Advice on optimal arrangement for range requests? w3c/IFT#110.
-
-
10 issues received 10 new comments.
-
Using WOFF2 files with range-request mechanism doesn't seem to be a viable option w3c/IFT#59 (1 comment by @garretrieger)
-
Static file compression compatibility with range-request method w3c/IFT#60 (1 comment by @garretrieger)
-
Populate suggested character ordering for range-request method w3c/IFT#61 (1 comment by @garretrieger)
-
Update range-request document to use same fetch language that patch subset document uses w3c/IFT#67 (1 comment by @garretrieger)
-
1 pull request merged.
-
Revamp the FeatureTagSet encoding scheme. w3c/IFT#149.
-
-
2 pull requests received 34 new comments.
Past meetings
-
1 meeting.
GitHub
w3c/IFT
-
1 issue opened.
-
Compremised w3c/IFT#152, by @Dangerfield77.
-
-
1 issue closed.
-
Compremised w3c/IFT#152.
-
-
1 issue received 7 new comments.
-
2 pull requests opened.
-
IFTB draft w3c/IFT#151, by @skef.
-
1 pull request merged.
-
3 pull requests received 3 new comments.
-
Update client and server handling to use "compression dictionary transport" headers w3c/IFT#153 (1 comment by @svgeesus)
-
w3c/ift-encoder
-
1 pull request opened.
-
Add a utility to extract and print client state (IFTP) from a font file. w3c/ift-encoder#73, by @garretrieger.
-
-
1 pull request merged.
-
Add a utility to extract and print client state (IFTP) from a font file. w3c/ift-encoder#73.
-
Past meetings
GitHub
w3c/ift-encoder
-
4 pull requests opened.
-
Add util to convert base64 requests into human readable. w3c/ift-encoder#72, by @garretrieger.
-
Add a public method to the client that can create the request from client state only. w3c/ift-encoder#71, by @garretrieger.
-
Pass through identity encoded responses. w3c/ift-encoder#70, by @garretrieger.
-
Use 'sbr' instead of 'brdiff' for content encoding. w3c/ift-encoder#69, by @garretrieger.
-
-
4 pull requests merged.
-
Add util to convert base64 requests into human readable. w3c/ift-encoder#72.
-
Pass through identity encoded responses. w3c/ift-encoder#70.
-
Use 'sbr' instead of 'brdiff' for content encoding. w3c/ift-encoder#69.
-
w3c/IFT
-
1 issue closed.
-
1 issue received 5 new comments.
-
Proposal would allow pages to learn how the user is interacting with the site w3c/IFT#50 (5 comments by @garretrieger, @svgeesus)
-
-
1 pull request opened.
-
1 pull request merged.
-
1 pull request received 5 new comments.
Past meetings
Participants
-
1 organization left.
-
Loongson Technology Corporation Limited left.
-
GitHub
w3c/IFT
-
1 issue closed.
-
1 issue received 8 new comments.
-
Proposal would allow pages to learn how the user is interacting with the site w3c/IFT#50 (8 comments by @garretrieger, @pes10k, @svgeesus)
-
-
4 pull requests opened.
-
Revamp the FeatureTagSet encoding scheme. w3c/IFT#149, by @garretrieger.
-
Recommend using unicode-range in incremental @font-face's w3c/IFT#147, by @garretrieger.
-
-
3 pull requests merged.
-
2 pull requests received 8 new comments.
-
Revamp the FeatureTagSet encoding scheme. w3c/IFT#149 (7 comments by @garretrieger, @skef, @svgeesus, @vlevantovsky)
-
Add a mechanism to client state that prevents re-requesting codepoints w3c/IFT#146 (1 comment by @skef)
-
w3c/woff
-
1 issue closed.
-
Typo: "wass" w3c/woff#24.
-
-
1 pull request opened.
-
Fix typo. w3c/woff#27, by @garretrieger.
-
-
1 pull request merged.
-
Fix typo. w3c/woff#27.
-
-
1 pull request received 2 new comments.
w3c/PFE-analysis
-
1 pull request opened.
-
1 pull request merged.
TR publications
-
2 documents published.
-
Incremental Font Transfer published as a Working Draft. History of Incremental Font Transfer
-
Range Request Incremental Font Transfer published as a Working Draft. History of Range Request Incremental Font Transfer
-
Past meetings
-
1 meeting.
Participants
-
1 participant joined.
-
Bianca Berning (W3C Invited Experts) joined.
-
GitHub
w3c/IFT
-
1 issue closed.
-
2 issues reopened.
-
Poor cacheing properties w3c/IFT#119, by @garretrieger.
-
Shared Brotli ID is expired w3c/IFT#101, by @svgeesus.
-
-
6 issues received 12 new comments.
-
Repeat fingerprinting analysis assuming a malicious font server w3c/IFT#42 (4 comments by @garretrieger, @svgeesus)
-
Create an explainer for the IFT Patch Subset specification. w3c/IFT#124 (4 comments by @garretrieger, @svgeesus, @vlevantovsky)
-
Proposal would allow pages to learn how the user is interacting with the site w3c/IFT#50 (1 comment by @garretrieger)
-
-
1 pull request opened.
-
Changes for /TR publication w3c/IFT#145, by @svgeesus.
-
-
1 pull request merged.
-
Changes for /TR publication w3c/IFT#145.
-
w3c/PFE-analysis
-
1 pull request opened.
-
Add privacy simulation results. w3c/PFE-analysis#102, by @garretrieger.
-
-
1 pull request merged.
-
Add privacy simulation results. w3c/PFE-analysis#102.
-
Past meetings
-
1 meeting.
GitHub
w3c/ift-encoder
-
4 pull requests opened.
-
Add additional set method for fontdata that allows both face and blob… w3c/ift-encoder#68, by @garretrieger.
-
Add virtual destructor to ServerConfig. w3c/ift-encoder#67, by @garretrieger.
-
All the font provider to be swapped out in server creation. w3c/ift-encoder#66, by @garretrieger.
-
Add the option for FontData to store a face. w3c/ift-encoder#65, by @garretrieger.
-
-
4 pull requests merged.
-
Add additional set method for fontdata that allows both face and blob… w3c/ift-encoder#68.
-
Add virtual destructor to ServerConfig. w3c/ift-encoder#67.
-
All the font provider to be swapped out in server creation. w3c/ift-encoder#66.
-
Add the option for FontData to store a face. w3c/ift-encoder#65.
-
w3c/IFT
-
1 issue closed.
-
Can't generate html w3c/IFT#143.
-
-
1 issue received 3 new comments.
-
1 pull request opened.
-
Update rfc9110 and rfc9111 to use section references. w3c/IFT#144, by @garretrieger.
-
-
1 pull request merged.
Lifecycle
-
1 charter started.
-
Chartered until 20 March 2025. Participants had to rejoin under this charter.
-
Past meetings
-
1 meeting.
GitHub
w3c/IFT
-
3 issues opened.
-
Can't generate html w3c/IFT#143, by @skef.
-
Condisderation w3c/IFT#140, by @svgeesus.
-
Privacy Considerations says checksum is for error correction w3c/IFT#139, by @svgeesus.
-
-
6 issues closed.
-
Condisderation w3c/IFT#140.
-
Novel, NIH things w3c/IFT#116.
-
Security self-review answers for IFT w3c/IFT#35.
-
I18n checklist answers for IFT w3c/IFT#36.
-
10 issues received 27 new comments.
-
Repeat fingerprinting analysis assuming a malicious font server w3c/IFT#42 (3 comments by @npdoty, @svgeesus)
-
Supporting fonts with composite glyphs via range-request w3c/IFT#58 (2 comments by @svgeesus, @vlevantovsky)
-
Proposal would allow pages to learn how the user is interacting with the site w3c/IFT#50 (1 comment by @svgeesus)
-
3 pull requests opened.
-
Update privacy section on checksums. w3c/IFT#142, by @garretrieger.
-
fix typo, fixes #140 w3c/IFT#141, by @svgeesus.
-
-
5 pull requests merged.
-
Update privacy section on checksums. w3c/IFT#142.
-
fix typo, fixes #140 w3c/IFT#141.
-
Remove PatchResponse from the specification w3c/IFT#137.
-
Make client state part of the font file. w3c/IFT#136.
-
-
3 pull requests received 13 new comments.
-
Split off the range request section back into a separate document. w3c/IFT#138 (9 comments by @garretrieger, @skef, @svgeesus, @vlevantovsky)
-
w3c/ift-encoder
-
1 pull request merged.
Past meetings
-
1 meeting.
Participants
-
1 participant left.
-
Bram Stein (Adobe) left.
-
GitHub
w3c/ift-encoder
-
2 pull requests opened.
-
Migrate from custom StatusCode to absl::Status. w3c/ift-encoder#63, by @garretrieger.
-
1 pull request merged.
-
Migrate from custom StatusCode to absl::Status. w3c/ift-encoder#63.
-
w3c/IFT
-
1 pull request opened.
-
Remove PatchResponse from the specification w3c/IFT#137, by @garretrieger.
-
-
1 pull request received 4 new comments.
Past meetings
-
1 meeting.
GitHub
w3c/IFT
-
1 pull request opened.
-
Make client state part of the font file. w3c/IFT#136, by @garretrieger.
-
w3c/ift-encoder
-
3 pull requests opened.
-
Update harfbuzz to latest version. w3c/ift-encoder#62, by @garretrieger.
-
Update to the latest emscripten w3c/ift-encoder#61, by @garretrieger.
-
Check cbor return values in tests. w3c/ift-encoder#60, by @garretrieger.
-
-
3 pull requests merged.
-
Update harfbuzz to latest version. w3c/ift-encoder#62.
-
Update to the latest emscripten w3c/ift-encoder#61.
-
Check cbor return values in tests. w3c/ift-encoder#60.
-
-
1 pull request received 1 new comment.